#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(?=[^\]]*(?:\[|$))(?=[^}]*(?:{|$))"
Local $sString = "RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\"(MEASURES_DIMENSION)\":\"006EI4ZXZALFXAT2E4AHX2O6V\",\"ZR_ITEM__ZR_BRAND\":\"0000000201\"},cell_selection,34932,#FFFFFF,,25,[{\"color\":\"#566C6C\",\"from\":\"10\",\"to\":\"50\",\"icon\":\"fa://minus-with-square\",\"size\":\"30\",\"angle\":\"45\"}]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")