using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=[^\]]*(?:\[|$))(?=[^}]*(?:{|$))";
string input = @"RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\""(MEASURES_DIMENSION)\"":\""006EI4ZXZALFXAT2E4AHX2O6V\"",\""ZR_ITEM__ZR_BRAND\"":\""0000000201\""},cell_selection,34932,#FFFFFF,,25,[{\""color\"":\""#566C6C\"",\""from\"":\""10\"",\""to\"":\""50\"",\""icon\"":\""fa://minus-with-square\"",\""size\"":\""30\"",\""angle\"":\""45\""}]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}