re = /,(?=[^\]]*(?:\[|$))(?=[^}]*(?:{|$))/
str = 'RR,target_value,006EI4ZXZALFXAT2E4AHX2O6V,006EI4ZXZALFXAT2E4AHX2O6V,dynamic,{\\"(MEASURES_DIMENSION)\\":\\"006EI4ZXZALFXAT2E4AHX2O6V\\",\\"ZR_ITEM__ZR_BRAND\\":\\"0000000201\\"},cell_selection,34932,#FFFFFF,,25,[{\\"color\\":\\"#566C6C\\",\\"from\\":\\"10\\",\\"to\\":\\"50\\",\\"icon\\":\\"fa://minus-with-square\\",\\"size\\":\\"30\\",\\"angle\\":\\"45\\"}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end