using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b((?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)(?:[^\s()<>'"",]+|\(([^\s()<>'"",]+|(\([^\s()<>'"",]+\)))*\))+(?:\(([^\s()<>'"",]+|(\([^\s()<>'"",]+\)))*\)|[^\s`!()\[\]{};:'"".,<>?«»“â€â€˜â€™]))";
string input = @"www.google.com(','dccccc)asx asx asx http://google/com,asd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}