const regex = new RegExp('(?i)\\b((?:https?://|www\\d{0,3}[.]|[a-z0-9.\\-]+[.][a-z]{2,4}/)(?:[^\\s()<>\\'",]+|\\(([^\\s()<>\\'",]+|(\\([^\\s()<>\\'",]+\\)))*\\))+(?:\\(([^\\s()<>\\'",]+|(\\([^\\s()<>\\'",]+\\)))*\\)|[^\\s`!()\\[\\]{};:\\'".,<>?«»“â€â€˜â€™]))', 'gim')
const str = `www.google.com(','dccccc)asx asx asx http://google/com,asd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}