re = /(?i)\b((?:https?:\/\/|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}\/)(?:[^\s()<>'",]+|\(([^\s()<>'",]+|(\([^\s()<>'",]+\)))*\))+(?:\(([^\s()<>'",]+|(\([^\s()<>'",]+\)))*\)|[^\s`!()\[\]{};:'".,<>?«»“â€â€˜â€™]))/im
str = 'www.google.com(\',\'dccccc)asx asx asx http://google/com,asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end