package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(movie|tv)\s*(.*?)(?:\s+season)?(?:\s+([0-9]+(?:\s+[0-9]+)*))?$`)
var str = `tv game of thrones season 1 2 3
movie inception`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}