const regex = /^(movie|tv)\s*(.*?)(?:\s+season)?(?:\s+([0-9]+(?:\s+[0-9]+)*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(movie|tv)\\s*(.*?)(?:\\s+season)?(?:\\s+([0-9]+(?:\\s+[0-9]+)*))?$', 'gm')
const str = `tv game of thrones season 1 2 3
movie inception`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}