import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(movie|tv)\\s*(.*?)(?:\\s+season)?(?:\\s+([0-9]+(?:\\s+[0-9]+)*))?$";
final String string = "tv game of thrones season 1 2 3\n"
+ "movie inception";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}