package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<li>(.*?)<\/li>`)
var str = `<ul><li>Чебурашка</li><li>Крокодил Гена</li><li>Шапокляк</li></ul>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}