re = /<li>(.*?)<\/li>/
str = '<ul><li>Чебурашка</li><li>Крокодил Гена</li><li>Шапокляк</li></ul>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end