using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!=.*[_.:;\-\\\/@+*]{2})(?=[^\d\n]*\d)[\w_.:;\-\\\/@+*]+$";
string input = @"ajh12-&
671%&i^
165271
agya678
yah@123
kj*12-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}