re = /^(?!=.*[_.:;\-\\\/@+*]{2})(?=[^\d\n]*\d)[\w_.:;\-\\\/@+*]+$/m
str = 'ajh12-&
671%&i^
165271
agya678
yah@123
kj*12-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end