$re = '/(?<year>[\d]{4})-(?<month>0[1-9]|1[1-2])-(?<day>0[1-9]|[1-2][0-9]|3[0-1])T(?<hour>[0-1][0-9]|2[0-3]):(?<minute>[0-5][0-9]):(?<second>[0-5][0-9])(?:Z|.(?<millisecond>[0-9]{2,3}))/mi';
$str = '2021-03-31T19:52:52.01
2021-03-31T19:52:52Z
2021-11-31T19:52:52.010
2021-12-31T19:52:52Z
2021-12-31T23:52:52Z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);