import re
regex = re.compile(r"(?<year>[\d]{4})-(?<month>0[1-9]|1[1-2])-(?<day>0[1-9]|[1-2][0-9]|3[0-1])T(?<hour>[0-1][0-9]|2[0-3]):(?<minute>[0-5][0-9]):(?<second>[0-5][0-9])(?:Z|.(?<millisecond>[0-9]{2,3}))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2021-03-31T19:52:52.01\n"
"2021-03-31T19:52:52Z\n"
"2021-11-31T19:52:52.010\n"
"2021-12-31T19:52:52Z\n"
"2021-12-31T23:52:52Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")