import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([(_)a-zA-Z0-9\\.\\-]{1,})(@)([a-zA-Z0-9\\-]+)(\\.)([a-zA-Z]{2,3})((\\.)([a-z]{2,3}))?)";
final String string = "\n\n"
+ "\"jj.jj@domain.com\"\n"
+ "\"hello@myemailadd.com.uk \"\n"
+ "\"HELLO@MYNAME.COM\"\n"
+ "\"japan@water.com.uk.uk.uk\"\n"
+ "\"me.me.me@domain.com.uk.uk\"\n"
+ "\"hello99@khalsa-aid.com\"\n"
+ "\"hello.me@myemailadd.com.in\"\n"
+ "\"hello.me@tax.gov.uk\" \n"
+ "\"my_name@council.co.uk\" \n\n"
+ "\"my-hello@bye-bye.co.uk\"\n"
+ "\"hello@my-99GOALS.co9.uk\"\n\n"
+ "\"Hello_Hello@two.com\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}