re = /(([(_)a-zA-Z0-9\.\-]{1,})(@)([a-zA-Z0-9\-]+)(\.)([a-zA-Z]{2,3})((\.)([a-z]{2,3}))?)/m
str = '
"jj.jj@domain.com"
"hello@myemailadd.com.uk "
"HELLO@MYNAME.COM"
"japan@water.com.uk.uk.uk"
"me.me.me@domain.com.uk.uk"
"hello99@khalsa-aid.com"
"hello.me@myemailadd.com.in"
"hello.me@tax.gov.uk"
"my_name@council.co.uk"
"my-hello@bye-bye.co.uk"
"hello@my-99GOALS.co9.uk"
"Hello_Hello@two.com"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end