#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*abc)(?=.*clean).*$"
Local $sString = "abc_clean.csv" & @CRLF & _
"abc_other_clean.csv" & @CRLF & _
"abc_something_clean.csv" & @CRLF & _
"abc_def.csv" & @CRLF & _
"def_clean.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")