using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*abc)(?=.*clean).*$";
string input = @"abc_clean.csv
abc_other_clean.csv
abc_something_clean.csv
abc_def.csv
def_clean.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}