re = /^(?=.*abc)(?=.*clean).*$/m
str = 'abc_clean.csv
abc_other_clean.csv
abc_something_clean.csv
abc_def.csv
def_clean.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end