$re = '/^(?=.*abc)(?=.*clean).*$/m';
$str = 'abc_clean.csv
abc_other_clean.csv
abc_something_clean.csv
abc_def.csv
def_clean.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);