#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*HbbTV\/1\.4\.1(\s|\t)\((.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);\)"
Local $sString = "Mozilla/5.0 (DirectFB; Linux armv7l) AppleWebKit/537.6+ (KHTML, like Gecko) Safari/537.6+ HbbTV/1.4.1 (;TCL; ; ; ; ;)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")