import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*HbbTV\\/1\\.4\\.1(\\s|\\t)\\((.*);(\\s|\\t)(.*);(\\s|\\t)(.*);(\\s|\\t)(.*);(\\s|\\t)(.*);\\)";
final String string = "Mozilla/5.0 (DirectFB; Linux armv7l) AppleWebKit/537.6+ (KHTML, like Gecko) Safari/537.6+ HbbTV/1.4.1 (;TCL; ; ; ; ;)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}