package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*HbbTV\/1\.4\.1(\s|\t)\((.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);\)`)
var str = `Mozilla/5.0 (DirectFB; Linux armv7l) AppleWebKit/537.6+ (KHTML, like Gecko) Safari/537.6+ HbbTV/1.4.1 (;TCL; ; ; ; ;)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}