package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"value": \"\d*\.\d*\;(\d*\.\d*)\;`)
var str = `"value": "0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}