const regex = /"value": \"\d*\.\d*\;(\d*\.\d*)\;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"value": \\"\\d*\\.\\d*\\;(\\d*\\.\\d*)\\;', 'gm')
const str = `"value": "0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}