$re = '/"value": \"\d*\.\d*\;(\d*\.\d*)\;/m';
$str = '"value": "0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);