// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"value": \"\d*\.\d*\;(\d*\.\d*)\;"#).unwrap();
let string = "\"value\": \"0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}