using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<First_Stop>\.[^\.]+)\.[^\.]+\.(?<Last_Stop>.+)";
string input = @".Madrid-plane.taxi$comp$uber.domestic$depart ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}