re = /(?<First_Stop>\.[^\.]+)\.[^\.]+\.(?<Last_Stop>.+)/m
str = '.Madrid-plane.taxi$comp$uber.domestic$depart '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end