using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{(?:\s*\[[^][{}]*])?\s*(.*?)\s*\}\}";
string input = @"Tags wrapped in <pre>{{ curvy }}</pre> tags should be ignored, but {~ others ~} should be removed";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}