$re = '/\{\{(?:\s*\[[^][{}]*])?\s*(.*?)\s*\}\}/m';
$str = 'Tags wrapped in <pre>{{ curvy }}</pre> tags should be ignored, but {~ others ~} should be removed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);