re = /\{\{(?:\s*\[[^][{}]*])?\s*(.*?)\s*\}\}/m
str = 'Tags wrapped in <pre>{{ curvy }}</pre> tags should be ignored, but {~ others ~} should be removed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end