package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\{(?:\s*\[[^][{}]*])?\s*(.*?)\s*\}\}`)
var str = `Tags wrapped in <pre>{{ curvy }}</pre> tags should be ignored, but {~ others ~} should be removed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}