using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(7[2-9]|80).*um en|abc0123";
string input = @"[72-80]% maximum energy shield
abc0123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}