package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(7[2-9]|80).*um en|abc0123`)
var str = `[72-80]% maximum energy shield
abc0123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}