$re = '/(7[2-9]|80).*um en|abc0123/m';
$str = '[72-80]% maximum energy shield
abc0123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);