package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\/]*\/level\/[^\/]*$`)
var str = `foo.bar/level/1A
foo.bar/level/1A/test
foo.bar/level/1B
foo.bar/level/1A/blabl/sdffs
foo.bar/test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}