import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\/]*\\/level\\/[^\\/]*$";
final String string = "foo.bar/level/1A\n"
+ "foo.bar/level/1A/test\n"
+ "foo.bar/level/1B\n"
+ "foo.bar/level/1A/blabl/sdffs\n"
+ "foo.bar/test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}