re = /^[^\/]*\/level\/[^\/]*$/m
str = 'foo.bar/level/1A
foo.bar/level/1A/test
foo.bar/level/1B
foo.bar/level/1A/blabl/sdffs
foo.bar/test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end