using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)Error\s*Message\s*\=\s*(?<error_message>.*)Register";
string input = @"31/05/2023 22:40:29 (01) >> Adyen Proxy::Proxy::RaiseValidResponse::Proxy event received -> Result : FAILURE ; Source : PROCESSPAYMENTFAILURE ; Message : Validation failed: Total amount is lower than configured min amount.
Error Message = Validation failed: Total amount is lower than configured min amount.
Register = 01
Store = tkg0452
host = tkg045201.store.tjxcorp.net
source = C:\ProgramData\GlobalSTORE\AdyenLog_5_31_2023.log
sourcetype = GSTR:Adyen:log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}