$re = '/(?ms)Error\s*Message\s*\=\s*(?<error_message>.*)Register/m';
$str = '31/05/2023 22:40:29 (01) >> Adyen Proxy::Proxy::RaiseValidResponse::Proxy event received -> Result : FAILURE ; Source : PROCESSPAYMENTFAILURE ; Message : Validation failed: Total amount is lower than configured min amount.
Error Message = Validation failed: Total amount is lower than configured min amount.
Register = 01
Store = tkg0452
host = tkg045201.store.tjxcorp.net
source = C:\\ProgramData\\GlobalSTORE\\AdyenLog_5_31_2023.log
sourcetype = GSTR:Adyen:log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);