import re
regex = re.compile(r"(?ms)Error\s*Message\s*\=\s*(?<error_message>.*)Register", flags=re.MULTILINE)
test_str = ("31/05/2023 22:40:29 (01) >> Adyen Proxy::Proxy::RaiseValidResponse::Proxy event received -> Result : FAILURE ; Source : PROCESSPAYMENTFAILURE ; Message : Validation failed: Total amount is lower than configured min amount.\n"
"Error Message = Validation failed: Total amount is lower than configured min amount.\n"
"Register = 01\n"
"Store = tkg0452\n"
"host = tkg045201.store.tjxcorp.net\n"
"source = C:\\ProgramData\\GlobalSTORE\\AdyenLog_5_31_2023.log\n"
"sourcetype = GSTR:Adyen:log")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")