// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?ms)Error\s*Message\s*\=\s*(?<error_message>.*)Register").unwrap();
let string = "31/05/2023 22:40:29 (01) >> Adyen Proxy::Proxy::RaiseValidResponse::Proxy event received -> Result : FAILURE ; Source : PROCESSPAYMENTFAILURE ; Message : Validation failed: Total amount is lower than configured min amount.
Error Message = Validation failed: Total amount is lower than configured min amount.
Register = 01
Store = tkg0452
host = tkg045201.store.tjxcorp.net
source = C:\\ProgramData\\GlobalSTORE\\AdyenLog_5_31_2023.log
sourcetype = GSTR:Adyen:log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}