package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<name>[Cc])hresti`)
var str = `Chrestiens`
var substitution = "${name}hréti"
fmt.Println(re.ReplaceAllString(str, substitution))
}