import Foundation
let pattern = #"(?<name>[Cc])hresti"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Chrestiens"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${name}hréti"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)