$re = '/(?<name>[Cc])hresti/m';
$str = 'Chrestiens';
$subst = "${name}hréti";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;