#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+)(?:[ ]+(.*))?"
Local $sString = "Interface Link Speed Duplex Type PVID Description " & @CRLF & _
"BAGG51 UP 4G(a) F(a) T 1 " & @CRLF & _
"FGE1/0/42 DOWN auto A T 1 ### LIVRE ###" & @CRLF & _
"GE6/0/20 UP 100M(a) F(a) A 1 LIVRE (MGMT - [WAN8-P8] "
Local $sSubst = "$1;$2;$3;$4;$5;$6;$7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)