$re = '/^(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+)(?:[ ]+(.*))?/m';
$str = 'Interface Link Speed Duplex Type PVID Description
BAGG51 UP 4G(a) F(a) T 1
FGE1/0/42 DOWN auto A T 1 ### LIVRE ###
GE6/0/20 UP 100M(a) F(a) A 1 LIVRE (MGMT - [WAN8-P8] ';
$subst = "$1;$2;$3;$4;$5;$6;$7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;