use strict;
my $str = 'Interface Link Speed Duplex Type PVID Description
BAGG51 UP 4G(a) F(a) T 1
FGE1/0/42 DOWN auto A T 1 ### LIVRE ###
GE6/0/20 UP 100M(a) F(a) A 1 LIVRE (MGMT - [WAN8-P8] ';
my $regex = qr/^(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S+)(?:[ ]+(.*))?/mp;
my $subst = '$1;$2;$3;$4;$5;$6;$7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";